Text not visible

Hello,

I put together a _very_ simple model consisting of a white background with a line of black text. When I simulate the model it works fine but when I run it on my RT 1050 EVB (running FreeRTOS) the text is not visible.

I have the existing Coffee Machine demo project which works fine on my board (text is visible) and I use the same C program to render my simple screen so it _should_ work!
I have tried changing the font type, and all sorts of other settings without success.

Does anyone have any idea what I am doing wrong?

Thanks & Regards,
Bob

0

Comments

2 comments
  • Hi Bob,

    It is possible that you have not exported the Resource Header file exactly right when you are generating the sbengine_model.h file.

    Can you check the 'Bitmap Fonts' option on the Export Configuration screen is not checked as we have not built-in the bitmap font support to the runtime that you are using?

    [Edit: Bitmap Fonts is set ON by default for new projects. We use full Freetype fonts on this platform so you need to deselect...]

    Regards,
    Garry

    0
    Comment actions Permalink
  • Hi Garry,

    Yup, that was it. Thanks again!

    Bob

    0
    Comment actions Permalink

Please sign in to leave a comment.

Didn't find what you were looking for?

New post