Working with Multiple Application Design Files

Storyboard’s collaborative features help multiple users develop applications faster. You can merge multiple files (*.gde) together and produce a single output during runtime. This tutorial explains how to create a project with multiple application files.

Creating a Project

A project with multiple application files starts the same as a single application file project. Select File > New > Storyboard Application or create a new project using the Photoshop Import feature.

A project can accommodate multiple stand-alone applications that share project images and script resources. You can add an additional application file to an existing project in multiple ways:

  • Create a new file within an existing project by selecting File > New > Storyboard Application and choose to create a New Model in Existing Project
  • Create a new file using the Photoshop Import feature and select the option to import .psd Into an Existing Project as a New File.
  • In the navigator view select and copy an existing application, then paste and rename the copied application file.

For a multiple application project to function as a whole, application files need to reference one another. Select the application from the Application Model View and in the Properties View, select Add external model resource button. In the next dialog select the .gde file that was created in Step 2 and press OK.

external_model_ref.png

To add layers from an external model to a local application:

  • Select the Import External Layer tab and then select Import Selected Layers.
  • Choose the layer(s) to add to the current screen. After adding an external layer, Storyboard will recognize the external content and incorporate it to function like any other layer.

import_external_layer.png

To create a transition from a source application screen to an external application screen, add actions to an application that perform a screen change.

external_screen.png

Before launching a multi-file application with the simulator, the external .gde files have to be referenced in the Simulator Configurations dialog.

To manage the runtime configurations, select Run > Storyboard Simulator Configurations. A list of available models that can be included in the runtime export used with Storyboard Engine is in the selected project folder. To apply changes, select Apply and then Run.

export_multi_files.png

If no conflicts occur within the selected applications, they are merged and converted into a single unified application at runtime. If conflicts exist, they must be resolved before the application can merge.

Resolving Conflicts

The application properties page provides an action to synchronize source content with referenced external content. Any differences are flagged as a conflict and the user is prompted to resolve the conflict based on the issue. Conflict types include:

Layers: If two or more layers have the same name their content needs to be identical.

Variables: Any application/global variables with the same name must have values that are the same.

Animations: If two or more animations use the same name then the animation needs to be identical.

Screens: Screens from all applications are compared. Two or more screens with the same name prompt the user to resolve differences between the two.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

0 comments

Please sign in to leave a comment.